TS1086: An accessor cannot be declared in an ambient context

This isn't an Angular error.

TypeScript 3.7 introduced a breaking change for getters and setters in the type definition files.

As mentioned above, TypeScript 3.7 emits get/set accessors in .d.ts files which can cause breaking changes for consumers on older versions of TypeScript like 3.5 and prior. TypeScript 3.6 users will not be impacted, since that version was future-proofed for this feature.

https://www.typescriptlang.org/docs/handbook/release-notes/typescript-3-7.html#class-field-mitigations

You should be using TypeScript 3.6 or higher if you're going to consume type definitions generated with 3.7 or higher.